Streaming live at 10am (PST)

Navbar stop area


#1

http://w20.webflow.io/

If you see on that page, and press the first link PROSJEKTER the page will go down to a black box with the topic prosjekter.

The thing is, if I press the eye and do it, the meny stops on top of the black box, but if i publish the site and look at it with the link I gave you, the menu lays on top of the black box.

I want it to stop in top of the box, so it doesn't cover the fint and the box. What do I have to do to make that happen all the time?

PS. It did work. It just suddenly didn't :stuck_out_tongue:

Thank you :smile:

  • Kjell Ruben

#2

To me, it works.

So, the rule is this one. If you want sections to stop on the bottom of your menu element, it has to be set as a menu element (HTML5 tag) in the settings panel:

If your nav element is the Nav widget from the add panel, the property is already set (and you can't change it).

You need to set it when your nav element is custom, or if you nested the Navbar widget into a bigger nav element (not recommended though, you end up with 2 html nav tag nested...)


#3

Also if you put the padding bottom on the send button instead of the section, the section will show up entirely when you click on contact.


#4

Thank you! :smile:
When I upload it to the server and check it on the domain, it actually works as well. So I guess its just when I check the site via the webflow domain.

But I learned something new, so thats perfect! Thank you!


#5

Hi again. This is still a problem, and I don't understand why it happens. Anybody who can help?

http://saeteraasenmaskin.webflow.io/ and http://w20.webflow.io/ is the two sites Im making that have the problem of the navbar going to far. any ide?


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.