Streaming live at 10am (PST)

Navigation Bar Link Trouble

Hi,

Currently, I am working on a website for my aunt: https://preview.webflow.com/preview/margret-de-jong?utm_medium=preview_link&utm_source=dashboard&utm_content=margret-de-jong&preview=195fda74d962928defcb2584a6c86147&mode=preview.

On the homepage, the navigation works fine (except for the page “Tarieven” which will be fixed when I have a good URL when the site is live), but when I view one of her treatments (Behandelingen) and try to use the navigation bar links from there they don’t work. Does anyone know how to fix this?

Would love to hear from you.

Kind Regards,

Selder Zwaan

Hi @Selderzz, welcome back to the forum. You have been missed. Anyways, your issue stems from incomplete links on the nav bar. Keep in mind when you are setting up your nav menu links, if they are not in a symbol container, they wont change across the pages.

Since you only have 4 pages at the moment, doing it manually is ok too.

Ive actually created a little video for you to review and hope this explains your problem: https://www.loom.com/share/bd49ef4c242444d885a1c5385d3ab5c9

Happy Designing,
Brandon

Hello Brandon,

Yea I sadly don’t have a fulltime job working with webflow :stuck_out_tongue: It’s more of a hobby so i’m not on the forum that often, thats why I reply so late :slight_smile:

Thanks for your reply that indeed would be a good & quick fix.

Hi @Selderzz,

That is not a problem at all. We are all freelancers or full-time employees somewhere.

Glad you were able to get things going though. LMK, if you need anything else.