Streaming live at 10am (PST)

Navigation in tablet help


#1

Hi there!

Sorry for the frantic message, launching my new site tomorrow afternoon!

I was just made aware in QA that when you click our navigation in tablet view (you can test this on your computer as well) and then click “customers” in my dropdown menu, instead of going to the customers page it opens the dropdown menu below that rather than going to the customer page

Please see screenshot

Here is my read only link and link to my site

https://preview.webflow.com/preview/appcues-042c3fa4a8ea0ab9197cdd376a405ca?preview=dadf93bfb7e096416aed5b17a4d1e9ed

Thank you!


#2

@Tanya_Higgins The reason this is happening is because you have got 2 main links wrapped in 1 dropdown container so when you hit customers because its in that container its dropping down


#3

Thank you so much for getting back to me!

I am a bit confused, i see the “customers” link above the resources container? Im not seeing it in the same container, so sorry im super confused by this

Thank you so much


#4

@Tanya_Higgins look at the first screen shot see the blue border around customers and resources read whats in the blue box and navigator dropdown both button are in the same block


#5

@Tanya_Higgins so no matter which one you hover its gonna open


#7

Hi! I still am not able to figure out what needs to be moved out of the folder to fix this? Please help my site is launching today


#8

Please see my two screenshots, i do not see customers within the same dropdown, the customer link is not in that same container

If it was in the same container i would just take it out of that container in order to fix this, but its a different container so i dont understand why this is happening


#9

@Tanya_Higgins I copied your screen shot and marked it green is your navigation, red is where both buttons are being toggled because your but is inside that toggle, move your customer button out side of the toggle of resourcesI matched the color to the navigator also


#10

Hi!

Please see my screenshot, the customer button is actually not in that toggle

I marked the customer button as pink and the resources files as teal, i opened each file and made sure it has nothing to do with the resources section so im not sure why it is doing this


#11

@Tanya_Higgins You just pointed out your own issue your customer and your resource link are wrap in that teal bock anything inside that box will trigger the drop down.


#12

But the customer link in the sidebar (pink) is not within the teal folder or wrapper


#13

@Tanya_Higgins watch what happens when i select your customer link and your dropdown when i select you drop down it highlights both links. if i select the drop down resources it should not put a box around customer


#14

Okay, so how do I fix that? I would assume it would be me taking the customer link out of there but its already out?


#15

@Tanya_Higgins in the navigator highlight navigation

and hit your delete key,

then duplicate your pricing and change the settings to customer of the duplicate


#16

thank you so much!!! this fixed it!


#17

@Tanya_Higgins Glad to help :smiley: