Streaming live at 10am (PST)

Navigation Menu incorrectly stored as a Hamburger Menu


#1

Hi,

I was trying to link one of the menu options to a section of the page. While this worked, the website now seems to incorrectly sandwich ALL the menu options under the hamburger icon when they should just be listed horizontally in the top section of the landing page.

Can someone please help me with this?

As you can see from the images, it looks very messy when trying to view the menu options from a sliding hamburger icon.

https://preview.webflow.com/preview/the-lighthouse-strategy?preview=7cfd4ad0eaa6f0040aaa354c126e3344

Thanks,



#2

You changed the default setting here:


#3

what should i change this back to? what is the default setting? would appreciate complete response.


#4

Basically you drag it to the largest size you want the mobile menu to show.


#5

Hi Abdulla!

@samliew is correct - it looks like you've accidentally set the hamburger menu to appear on all break-point sizes. Use the Navigator (hotkey is "F") to select your Navbar element from the hierarchy, then go to the Settings (hotkey is "D") to see the following options:

The slider I highlighted above allows you specify at which breakpoint the hamburger menu will appear (and therefore, the inline linkblocks will disappear). In the screenshot, I have it set at the portrait tablet breakpoint (which is where I think you want it to be). If you set this to the largest breakpoint all the way to the left (desktop), your hamburger will always appear. Basically, you can tell Webflow to never display the linkblocks and always display the hamburger menu this way.

Sounds like you want to slide it over one notch though, so that your linkblocks will show on the full-width desktop breakpoint. You basically want to adjust this setting whenever your navbar linkblocks get too wide for the breakpoint that you're on. If you don't have too many links at the top, you could (for example) show the full menu on portrait-oriented tablets or even phone breakpoints. But, if you have too many linkblocks and they start to spill over the next line or something, you can tell Webflow to show the hamburger instead.

Hope this helps! :sunny:

Best,
Zack @ MetaFlare Media & Design


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.