Streaming live at 10am (PST)

Navigation Symbol not working


#30

Ah! Sorry about that. I have my link blocks named “navlinks” and confused myself. This works now. Thanks… never apposed to hacking it :slight_smile:


#31

No need! :slight_smile: Glad it’s working now :smiley:


#32

My nav bar has nav links not link blocks but it’s still not working.

Read-Only Link >> https://preview.webflow.com/preview/stce?utm_source=stce&preview=bf2f1a4e6ba8a5c46a5cf38646b26f35


#33

Hey @JustJoe The text span on the Vendor Contact link is being classed as a child of the Navlink ( I think) , which on this version is not allowed, although it should be.

The fix in question that I’ve tested solves this and will allow you to use the jump link once again.


#34

Ok, so it’s two different things right? My issue is the jump link, other people’s issue is link block vs navlink? Both are creating the same error?


Webflow Workshop #91: Meet the team behind Webflow
#35

reasons i do not know of, but i can’t seem to use my navigation symbol anymore on any page on my website. have been told it might just be a bug, but i keep getting the error message ( nav link cannot be placed out if its nav menu ).
if you can help please do


Webflow Workshop #91: Meet the team behind Webflow
#36

Exactly that, they’re two issues inadvertently connected. Fix coming soooooon :slight_smile: :tm: :crossed_fingers:


#37

Hi @JustJoe, @yzhou, @domo, @clinton & @ON2Interactive We just deployed a fix for the Nav Link and similar errors! Please let us know if you’re still having problems after refreshing the designer and working with your sites!

Thank you so much for your patience! Sorry for the frustration! <3


#38

It works great thank you!

M


#39

Great to hear! Thanks for reporting back @Mat_Griffiths! :blue_heart:


#40

Working for me! Thanks!!


#41

All good… Thanks much!


#42

:tada: Wahoo! Thank you both!


#43

Read this thread and was hoping that my issue was the same but I think it’s different @iammerrick @magicmark

My error is “Dropdown Link can only be pasted in a Dropdown list”

It was a symbol, I removed the root symbol…nada. No fix. I do have nested dropdown links but I’ve done this before with no issues on another site.

What am I missing?

https://preview.webflow.com/preview/vma-hollander?utm_source=vma-hollander&preview=5ea4fedfec5a188b47f98d9709b0a8d7

Thanks in advance for your help!


#44

Hey @n3tworth,

Would you be Ok to try and load your designer in incognito mode and add a fresh dropdown link to see if you have the same issue.

Thanks in advance! :crossed_fingers:


#45

ok I figured it out…the dropdown links were placed inside of a div (originally for styling purposes) but then gave the error upon moving it.

After pulling the dropdown links from the encasing div box and pushing them back up under the original dropdown list, I was able to copy the navbar to another page.

Subsequently, I can’t move the links BACK into the div…maybe there’s a version conflict? The styled drop-down lists were copied over from an older site…


#46

On your site, you should be able to add any element inside a dropdown link and you should be able to add a dropdown link inside any other element. I"m not sure entirely why you were having the issue. :grimacing: :thinking:

Can you now copy the dropdown link between projects and pages?


#47

Hi @n3tworth, we’ve found the problem and are working on a fix. It should be complete within the next few hours. Sorry for the inconvenience.

Thanks,
-Andrew

// @magicmark


#48

Yes without the encasing div block I was able to copy/paste to other pages :slight_smile: So it works this way :slight_smile:

System WILL let me:

  1. Add any element inside drop down list

System WILL NOT let me:

  1. Move drop down links inside of another element (in this case a div block) that is also nested inside that drop down list. The drop down links can only be directly nested inside the drop down list. Can’t shove it inside of a div to group my little links :frowning:

Not sure if there’s a good reason for that but that’s why it wasn’t working for me earlier.


#49

Hi @n3tworth

Our team was able to push a fix for this last night. Can you please refresh the Designer, then try adding that symbol to the page once more and let me know if it’s fixed on your end?