Streaming live at 10am (PST)

Navmenu opens once then breaks on iOS Safari


#1

I've been fidgeting with the hamburger menu for a while now. I finally have it close to the way I want it. However, neither my client nor myself are able to open the menu more than once on an iPad or iPhone. I am using Safari on both. Chrome seems to work okay though.

Any help would be great :slight_smile:

Here is the sharable link!


#2

Hello @Hamilton . A webflow share link would help to further diagnose where the problem could be.


#3

I added the link to the original post :smiley:


#4

First of all, thats a great looking site right there. Looks like you have two nav menus (guessing they are the same right and left in the desktop layout) in the navbar and the latter is set to 10vh. A good practice is to let let elements in the navbar flow. The 10vh height of the navbar allows the nav menu that has a higher z index of 50 to be shown once but gets conflicted by the second menu which is inheriting the z index of the navbar hence does not show when you tap a second time.

Let me share a link with you in 15mins of how you can set this up to work flawlessly.


#5

Awesome! Thanks for your help @AlexManyeki!! You're a life saver! :grin:


#6

@Hamilton Your are welcome. That took longer than expected. Here you go;

Example Link

Pay extra attention to the menus flex layout and hide elements based on media queries. Let me know if it works for you.


#7

Thank you @AlexManyeki! That was super helpful
:smiley:


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.