Streaming live at 10am (PST)

Need help getting collection items to display properly


#1

Hi everybody,
For some reason the collection items I have on the homepage are not displaying neatly in a 3x3 grid. The the 7th item is out of place. And the second problem I’m having is making all the image captions disappear BUT to only appear when someone hovers over the respective images. I tried changing the state to hover and changing the display settings but that just made it disappear completely. Any help will be great appreaciated.
The read-only version can be viewed at My Site



#2

Hi, go to your “Collection List” wrapper and set to ‘Flex’… then wrap children. Additionally, the sizing of the div boxes could stretch if you wanted them to, so they’re all the same (size/height) regardless of content. You can find that in this tutorial: https://university.webflow.com/article/equal-height-layouts-with-flexbox

Take care.


#3

@garymichael1313 Thanks for helping to get it to display properly. I managed to get them to be equal size and height! Now I just got to find a way to get the hovering effect.


#4

Awesome, glad to help… have a great day.


#5

@Eden21 for the hovering effect, try this:

If you do this you should be all set

Let me know if this helps.


#6

@justin_c thanks I was able to get the hover effect working. But I ended up reverting back to the old style because it looks better. But thanks anyways.


#7

@Eden21 glad to hear you’re all set now! If you’d ever like help with functionality (no matter how advanced) or design with any site feel free to DM me as I do freelance Webflow work as well.


#8

Awesome, I’m gonna have to take you up on that offer! :slight_smile:


#9

It’s not the “collection list wrapper” that needs the flex and children wrap, it’s the level below, the “collection list”!


#10

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.