Streaming live at 10am (PST)

Need help with 3D transform overflowing viewport


#1

I have button....which is inside a container....which is inside a section.
Everything looks great until I switch to tablet or mobile mode....then the button bleeds off the edge of the screen.


Here is my public share link: LINK
(how to access public share link)


#2

Can you please share a public share link? Thanks! :wink:

https://help.webflow.com/article/how-do-i-share-my-sites-read-only-link


#3

Here you go

https://preview.webflow.com/preview/goeliteortho?preview=01cbb12cd80731fa96484e0b3746fb17


#4

For some reason I get a 404 page, can you please try again?


#5

Alright...
Try this one:

https://preview.webflow.com/preview/goeliteortho?preview=01cbb12cd80731fa96484e0b3746fb17


#6

Try to remove float : right on your button and set text-align : right to your hexpander CTA div


#7

You have 3d transforms set on your hexpander CTA that is causing the container to be larger than the viewing area. Remove the 3d transforms on mobile and you should be able to place your CTA button using the right-margin setting. You'll lose the interaction, but there is no hover on touch devices anyway, so you won't notice in actual use.


#8

Thank you very much.


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.