Streaming live at 10am (PST)

Need help with custom nav animation


#1

Just wondering if theres another interaction bug going on?

I'm working on this new project, and I made a custom Nav Menu with interaction. This is taking up the entire screen, so when using symbols, it block the page from editing. So I opened it and click Display none, so that I could edit the page.... When turning the Nav Menu 'back on', the interaction is not working anymore.
Very frustrating.
Does anyone else have the same kind of trouble?

(PS! sorry for any bad explanations here... my English not so good)

Sharing link: https://preview.webflow.com/preview/javier-reche-garay?preview=139fea7fb31172c5ec862914c1642241


#2

Hi @Sven_Erik_Slattedale thanks for reaching out!

This is actually not a bug, your interaction when clicking your "navbar burger" element didn't have a display: block style for the affect other element settings on the "Nav menu" and "Nav menu Flex" elements.

Here's a GIF showing how to make this interaction work: https://cl.ly/3L0m1H0k1U1W

Hope that this is helpful! :palm_tree:


#3

Hi @Waldo!
Thank you so much fory your help... again! You always seem to be there to save me, and I'm so greatful for that!

It did help a lot, but... and there's two but... The first thing is... I never did touch the interactions, so how come this happened all by it selves? All I did was to go to styling and set Nav burger and Nav Menu to Display none, and when turning it back on, it didn't work. I find that very strange.
Anyway... with your help, it is working now.

The second but..... as you can see from your Gif as well, the Nav menu dosent cover the entire page...something it did before this happened. Any suggestions on how to fix it, and why or what caused it?

Thanks again for all your help!


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.