Streaming live at 10am (PST)

New site with partial Mega drop down menu


#1

Hey Everyone,

Getting close to the end of the travel blog website. Some small bugs to work out but over all looking nice. I made this menu myself out of divs and interactions. functions fine across the board except on mobile I cant get it to work.

Let me know what you think of the blogs design, if you have any ideas, and what you think about the menu and if you have any bug fixes.

I was also considering making the banner images at the top of each page 100VH and hiding anything outside the frame but am not sure how (on mobile) if you check out the landing page on mobile you will see its super stretch out and then on all other pages its fit to width. Thought?

https://preview.webflow.com/preview/xplormor?preview=296de3a35b3dac9689d61501936cea54
http://xplormor.webflow.io/


#2

nice logo - and nice photos. the website needs some fine tuning.

the menu button is really hard to find - i didn't know where it was. you need to make it much more obvious. you also need to change the cursor to a pointer on hover so that users know it's clickable.

and also the submit button hanging out the bottom of the drop down looks out of place.

what did you use to add in the instagram photos? the cms? or a plugin?


#3

Diarmuid is right, menu button is hard to find for some people.
Anyway the button and other elements are not visible in Safari for Mac ... check your positioning, maybe z-index ?
Be careful with distances between elements, text to borders etc. keep more white space alltogether.


#4

Where is the menu button ?

I'm on an iPad Air 2... don't see way to activate a menu.

I'll try on a Chromebox in a couple minutes.


#5

Thanks for the input!

The IG band is from a website called "LightWidget"


#6

That was the issue I am having the menu button doesnt appear on anything smaller than desktop and im not sure why


#7

confirmed... doesn't display on a tablet. Saw it on a desktop. You should change the color to make more pronounced.

The menu button appears in Preview / Tablet.... but not Published / Tablet :frowning:


#8

Cool - I know the widget! thanks

best of luck with the launch!


#9

#10

#11