Streaming live at 10am (PST)

New Style Panel Feedback


#65

Also depends on your screen size.


#66

Nothing. They will continue using it.


#67

Hi. I am late to the conversation… so someone may have already mentioned this. I am using Webflow on 2 Macbook Pros. I am using Chrome browser. On both machines I don’t see any scroll bars on the New Style Panel… so I can’t access any functions at the bottom of my browser screen (the Old Style panel display the scroll bars just fine).


#68

Just scroll as usual. Scrollbars are disabled (invisible) unless you are actually scrolling hovering your cursor over the sidebar.


#69

Sorry… it still doesn’t scroll (as usual). But if i collapse the sections I can access the bottom of the screen…although that requires extra work I can make do with it for now (so I can try working with the new panel).


#70

Yep, sounds like a bug. Does it scroll in safari though?


#71

Sorry … no scroll bars in Safari either. I will use the expand/collapse functionality for now.


#72

I mean does it scroll when you scroll with the mouse wheel or touchpad? No scrollbars is not an issue itself I guess.


#73

I’m going to have to come back to it, because I really don’t have the time to do tutorials right now.

But I will say that if the option is complicated to the point that it does nothing at all (definitely not what it says it does) if not used in exactly a certain way, a detailed tooltip is likely warranted. It looks like a really fun and useful button to push, and you’re going to have some heightened frustration for new users when it doesn’t do what it appears to say it does.


#74

Wow, the new style panel is awesome. I have one minor issue though - I’ve been a little frustrated because on properties like text shadow, the little “+” icon is tiny and takes a bit too much concentration to click. Why not allow a click anywhere on the section/wrapper? It would make my life much easier.


#75

+1 to this! Totally agree. :slight_smile:


#76

Yes… trackpad scrolling works and mouse buttons work. It was my mouse settings that messed me up… I am an old guy and drag my mouse for scrolling (so I had shut off the scroll buttons on the mouse). I think my case is unusual – so no need to fix anything.


#77

Your harsh criticism is totally unwarranted in this instance. Most of the webflow interface buttons won’t just do something “fun” unless you know (or at least have a vague notion of) what you’re trying to do.


#78

harsh

what?

Doing new things in your builds is fun. Having a sticky element and being able to accomplish it by just clicking a button is fun. Harsh criticism? I have an element I want to be sticky. I click the button that says “sticky” and nothing happens. I think that is a problem. You call that “harsh criticism”?

I have a difficult time believing you do anything web related as a job if you respond this way to a question that amounts to, “Why does this feature not work in a way that it appears it should or could?”


#79

You really need to calm down a bit of you want to have any kind of meaningful discussion.


#80

As a matter of fact you are the second person (and that is only among those with whom I’ve spoken here on the forums) who had problems with the dissapearing scrollbars. The other guy was using a stylus as a pointing device and also relied on the bars to scroll the content.

The solution is pretty simple though, I don’t know why WF didn’t implement it from the start. Show the scrollbars on hover not on scroll event. The bars are tiny and not intrusive any way even when they are over the elements in the panel.


#81

Thanks. That works for me.


#82

Hi again, @Cricitem

For make an element “sticky” you need to:

  • select the “position: sticky” option in the style panel
  • set the top/bottom/left/right/ position according to your needs (without applying any position settings browser doesn’t know where to place the element during the scrolling)
  • :warning: make sure non of the parent (ancestors) elements have an overflow: scroll or overflow: hidden settings. (Currently It is a CSS limitation that creators of position: sticky property still working on and it might change in the future)

If you still have problems with applying position: sticky to the element, please, feel free to PM me with the link to your project. I will be glad to create a screenrecording explaining how to achieve the result you need.

Best regards,
Anna


#83

https://preview.webflow.com/preview/kittanningmap?utm_source=kittanningmap&preview=49993c0523db766356cc36a1c6577c0e

Search bar should be sticky. It simply isn’t working. There is either some esoteric requirement that is not explained on the tool itself or it’s broken. I believe it’s the former.


#85

There are many different settings that affect element’s position and which may interfere with each other’s placement and behaviour.

In your case you forced your searchbar to be at the bottom of the parent with justify: end on the hero section meaning there is no space for the search bar to move being sticky - the parent is done being in viewport at the time search can be visibly sticky so to speak. Make the hero have justify: start parameter and the search will behave as it should.