Streaming live at 10am (PST)

No smooth scrolling?


#1

Hi, looks like there’s a problem with scrolling on my website: it is definitely not smooth, and I don’t know why.
Does anybody know how I can fix it?


Here is my site Read-Only: https://preview.webflow.com/preview/nici?preview=4d8b73c09a1106041a15eab130ad2185
(how to share your site Read-Only link)


#2

Looks fine to me… I really like it… try adding custom attribute to the body by clicking settings… data-scroll-time can give you a better indication of the speed. There’s a number of articles that will help:


https://webflowcodestutorials.webflow.io/body


#3

Hi @lindalderigi,

I’m not sure why that’ s happening but I noticed something on your site, your images are really heavy… redpla-04.png is over 3 MB, which doesn’t help. You should compress your images with something like Tiny Png and upload them again - https://tinypng.com/.

If that doesn’t help, I think the problem might be related with an interaction. Disable all your interactions and see if the problem persists. If this fixes the issue, start enabling each interaction one by one and testing along the way, so you can see which one is affecting your scrolling.

Hope this helps.

I noticed one more thing, your site is displaying horizontal scrolling. You should fix that - set the overflow of section 2 to hidden.

Cool website, by the way :+1:


#4

Thank you for the tip! I tried it, but it still doesn’t work :frowning:


#5

Thank you very much! My images were actually too large, I resized them but still no smooth scrolling. I even tried on a copy of the project deleting all the big images and interactions, but still nothing. I hope webflow support will help me fix that…
Thank you again :slight_smile:


#6

Sorry to hear that :anguished: … I really thought an interaction was causing the issue. Maybe @webflow can help you.

Good luck on your project :slightly_smiling_face:


#7

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.