Streaming live at 10am (PST)

Non existent AAAA records causing issues with hosting

#1

Hey there, I’m trying to get the hosting to work on a website that I’m working on.

The domain is purchased off of google, and when using google as the DNS I’m able to connect to it successfully, I do however get a “too many redirects” error when I try to access the website.

I’m trying to use Cloudflare for my DNS now, however, when I try to use cloudflare rather than google, I’m told: “You’ll need to remove the AAAA record from your DNS settings to ensure your site loads properly.” inside of Webflow. I made sure those AAAA records are deleted.

Additionally, any suggestions for why I was getting the redirect error with google’s DNS? I made sure the only records available in G-Suite were the two A and one CNAME records.

Thanks.

Link.

https://preview.webflow.com/preview/serenity-mountain?utm_source=serenity-mountain&preview=09708085080bc4808fe1947644a58757

#2

You have cloudflare setup to tunnel all of the traffic through them (instead of only using them for DNS)

Webflow SSL does not work when it is behind cloudflare (we can only provision ssl certs when your site is directly pointing to us)

Additionally, when you use cloudflare, it does set AAAA records, even if you don’t set them yourselves. (You can see that here: https://dnschecker.org/#AAAA/serenitymountainutah.com)

To fix all of the above issues, clicking the orange clouds in the screenshot will make it so you only are using cloudflare for DNS.

Let me know if that doesn’t resolve the issue!

#3

Beautiful. Sorry for making you have to check into something so simple. It’s working now.

#4

@Daenon_Janis

Based on your screenshot you have proxy enabled,

Does set to DNS only work for you. Click the icon to disable proxy, and wait up to 24 hours (1-4 hours typical). See screenshot.

Also set your alias webflow TTL to 600s or 10 minutes for more immediate publish to live propegation

(my cloudflare refresh instances usually take 1-2 hours)