Streaming live at 10am (PST)

Non existing pages are being indexed by on site search

The on site search is taking me to a non existing page when inputting “Edello” as a search term and linking to a non existing page. Is this a bug or expected behavior?

You can replicate the issue by searching for “Edello” and clicking one of the empty links. A bunch of links will pop up pointing to a non existing site.

One of those pages are https://www.edello.se/sku/ullplad-bla-m-ljusa-fransar

ezgif.com-video-to-gif


Here is my site Read-Only: Webflow - Edello
(how to share your site Read-Only link)

Hi, is that “Edello” is a collection or CMS item you created before and deleted?

You could hit the gear icon on the left (Settings), Site Search, and then manually re-index your site.
Please note that you cannot manually index your site frequently.

You may also find this useful:

No, Edello is the name for the website. No collection by that name has been created in the past. And I re-indexed the site today. I also find the “sku” in the url kinda strange.

I see you have already marked possibly every “Edello” to exclude from search. lol

You will also have to set up the “Site Search Settings” of your “Product Template”, and wait for re-index.

Not sure this will solve or not. Hope it helps.

Exactly. i will re-index tomorrow and see if that fixes it. But this really seems to be a bug.

I have re-indexed the site with no luck. The issue persists. Any other ideas? Is this a bug?

Hi, as said, you have to set up the site search settings.
I see it is still missing from your read-only link.

Could you explain what I should do in the search settings? Should I exclude the page from search results? Because I need the product template visible in search, that is the only page that I want to be searchable.

Hi @Webflow-user
I am having the exact same issue. My site search settings are actually set up like yours too. I’m not understanding why @anthonychan2509 is saying something’s missing as the search functions fine except for showing “non-existing” sku pages in the results.

I am opening a support ticket to find out why these mysterious /sku pages are being generated and indexed when I have not put in any skus and can’t find/access sku pages anywhere internally.

My site is also indexing the footer symbol, which is NOT expected behavior.

I’ve read a few other forum posts on this strangeness where it was recommended to reach out to Webflow support.

I’ll return with any new info that might help!

Huge thanks! I really hope that the Webflow support team can help us resolve this, it really bugs me out.

Hi!

Any update from the support team?

Hi there, not yet. I submitted a ticket two days ago, and the auto reply said they were experiencing a high volume of requests. I’ll post here once I hear anything! Also, I see what you did there… :ant: 'n :stuck_out_tongue_winking_eye:

1 Like

Hello again, Webflow customer support replied today and said they are passing it to their internal team. I will follow up when I know more.

1 Like

Great! I hope they find a solution and cause of this.

Hello again! Customer support said their Webflow engineers know about the issue but they don’t have a timeline for a fix. That was the last I heard. I’ll pass along anything else I can find out. But it seems I’ve hit a dead end.

1 Like

Well that’s a bummer. It’s really embarrassing to have this bugg on a site with no way to fix it. I hope they push a fix for this sometime soon.

Thank you for the update!

I agree! You’re very welcome.

1 Like