Streaming live at 10am (PST)

Not receiving form emails (G Suite related)


#1

Hi, everyone.

My client is having a trouble I can’t fix and have no idea what is causing it.
He set his email (the one used at the form subscription) on G Suite and since then he no longer receives the forms submissions. He didn’t have that problem before setting his account on G Suite.

Does anyone know what could be causing it?
Thanks.


#2

Without knowing how it was set up, we can’t provide any answers. Perhaps you can provide as much details as you can gather?


#3

Here is my client’s testimonial:

I changed my business email erelab@erelab.com.br (the one configured to receive the form submissions) to G Suite. From this moment on, the form messages started to be directed to my Spam Box and after a few days stopped being received at all. I do receive email from other senders, though.
I erased all MX records from my hosting panel to make sure there wasn’t trouble with G Suite.

I called Google and I was told it was a development issue, that I should edit the IMAP outbox so it would recognize Google as the way out.
I called the hosting provider. They accessed the website and made some tests on the forms. I was told to way 24h but nothing happened. I called again and they couldn’t solve it.

I talked to the designer who made the website and she made a test: she changed the form subscription email to roni@erelab.com.br (which is also set as G Suite) and I started receiving the submissions.


#4

What was the last email’s content that was sent to the spam folder for erelab@erelab.com.br?