Streaming live at 10am (PST)

Not receiving form submission notification emails

Hi there, I have a contact form set up on a landing page I’ve recently created. The form submissions are showing up as received in the Webflow Site Settings under “Submission Data”, but I’m no longer receiving email notification of the submissions. It was working just fine as recently as last week, but something has happened in between then to cause an issue.

For some additional context, this project is currently being served on WordPress and is being served via the Webflow Pages plugin. Just to be sure, I did a test form submission on the webflow.io domain to make sure it wasn’t an issue with WordPress. Sure enough, after submitting on Webflow’s own staging domain I’m still not receiving email notifications. Any idea what’s going on here? As I said before, the notifications were working as recently as 8 days ago while living on this WordPress site, so I can’t seem to figure out what’s happening.

Thanks in advance!

Here’s my read-only link: https://preview.webflow.com/preview/hollow-spirit-producer-application?utm_medium=preview_link&utm_source=designer&utm_content=hollow-spirit-producer-application&preview=ac6222410728613fe0fd16227e2c7a67&mode=preview

IMPORTANT: this channel is not maintained by our Support team.

For outages, please check: https://status.webflow.com/

If you have an issue with your account or experience any bugs on the site, please contact our support team directly: https://university.webflow.com/support (this is the best way to communicate bugs to our team and get the fastest help and updates).

The Webflow team does not maintain this category with updates on outages or bugs.

I’m facing the same issue on my projects that should have form submissions. And I have faced that a couple of months ago, as well. The problem was solved even earlier than I received an email from support team to my request. So I guess, it’s a bug that appears rarely but it’s gonna be solved soon.

Same, looks like Webflow is having a massive bug. Three of my website on one account, plus another website on another account, all of them are not receiving any notifications.

Same for me on all sites

Same here.

Changed where the form email was being sent (thought I might have accidentally unsubscribed as referenced in a previous form/email issue) but still not receiving any. Shows up on the form submission data in Webflow (and being received by Zapier) and not in any spam folders so looks like its a Webflow email sending issue.

Hi all!
It’s a global issue. Webflow support told me they were fixing it. Hope it’s going to be solved soon.

UPD:
Now everything seems working fine. At least I got a bunch of form submissions for the last 24+ hours from all of my websites.

1 Like

Thanks for the update - I believe it’s fixed now too. Looks like Webflow was having some issues.

1 Like

Nope not fixed. Not receiving any.

1 Like

I’m not receiving any emails too. They are arriving to Webflow but not being forwarded on.

I’ve set up Zapier to email me them for my site for the time being. Easy work around while they fix the bug.

Experiencing the same issue. Please someone investigate.

1 Like

I had to use Zapier to get the form to work, it’s a bit of a hassle but I eventually got it to work.

I had to use Zapier to get the form to work, it’s a bit of a hassle but I eventually got it to work.

Hi Webflow Support team,

Just letting you know that none of our websites form submissions are being received today either. They were working yesterday but have stopped today. Can you please let us know that you are working on fixing this. One of our sites is a school and the only form on the site is the Absences form, so it’s vital that this is fixed asap.

Thank you.
Grant

1 Like

Having the same issue.