Streaming live at 10am (PST)

OG settings missing in Webflow sites

While social posts for webflow sites do populate with the existing webflow page OG settings, the facebook debugger reveals warnings.

eg https://developers.facebook.com/tools/debug/sharing/?q=https%3A%2F%2Fwebflow.com%2F

So a webflow site will get the following warning:

The following required properties are missing: og:url, og:type, fb:app_id

Webflow is creating manual error prone work for static pages where we have to add manual custom canonical url and now we need another for og:url. :neutral_face:

3 Likes

Canonical is already supported by Webflow through custom attributes, ad a rel=canonical to any page, or use custom code on <head> to add it to certain CMS content. However that would be cool to have this option at page level, maybe.

og:url, og:type, fb:app_id are really for Facebook business. The first one prevents fb to scrape further away, type is for how the Like button will be handled and to last one is self explanatory.

What in your use cases absolutely requires that you have the url and type attributes? (genuine question :slight_smile: )

Opinion — that is personal, obviously: The OG tech is really useful and the fb scrapper very effective, but do we have to craft our sites for Facebook? We’re already bullied by Chrome into having all of our site SSL for no valid reason, let’s not feel obliged to follow Facebook rules and clutter our tools.

3 Likes

I am just reacting to tests that say “Needs fixing” according to FB and other testing tools. My only use case is I want to deploy right for clients and FB is the other channel for many (for now).

I guess as long as the preview card is visible in posts then all is ok ??

I know what you are saying with regard the bullying . But I see most sites have these extra og properties. I guess regardless what I would like is the ability to add dynamic urls or any other site/page attributes via custom code on static pages for when the need arises. That would avoid the feature setting bloat and minimise errors.

1 Like

In that case, is there another tool that is reporting those fb errors?

That really depend on what you’re doing. if your website is tightly tied with fb things, using an app, using comments etc, you surely want to be fully compliant with them. But that’s really them, fb, a private company, as big as it is. It’s one things to natively support private products such as maps, Youtube etc within the Webflow UI, because they are features, it’s another thing to support their custom attributes who don’t bring any feature to your site.

I don’t see how you can be penalized for not supporting them. (only did a quick search though).

1 Like

Hi @vincent

I get the same warning message: “The following required properties are missing: og:url, og:type, fb:app_idas” as @HammerOz despite having the image url set in the Open Graph Image URL.

I can see the url set in the page html at https://www.remortgagehub.com/lp/facts

I’d like to get this warning resolved because it can have a positive effect on advertising costs (lower CPM) on FB. So it really is important, particulary for your ecommerce user base running FB ads. Can you advise if/how we can get rid of this warning please.

Thanks

2 Likes

Did any one resolve this?

I had the same issue as @HammerOz.

I am using a custom collection and even though the below statement is true, FB is used so widely that I feel like it makes sense for it to be optimised there also

The OG tech is really useful and the fb scrapper very effective, but do we have to craft our sites for Facebook?

Yeah… my own client pointed out these errors to me.

Warnings That Should Be Fixed

  • Missing Properties
    The following required properties are missing: og:url, og:type, fb:app_id

Kinda embarrassing when the client points this out. via https://developers.facebook.com/tools/debug

If this costs my client more as @GrahamCox seems to point out, that also makes me not look so great. Hopefully, this high on someone at Webflow’s todo list? At the moment, I don’t have a clue how to manually fix this for every page. I literally showed the SEO section per page to the client as “see how awesome this platform you’re paying for is!?” :sweat_smile:

The main thing to test if is you drop the url into a Facebook post, does the content show. If so, happy days, next project :grin:

1 Like

Unless if @GrahamCox is correct with:

I’d like to get this warning resolved because it can have a positive effect on advertising costs

How can I verify this? The client is currently on a shoestring budget, so very penny counts (even more directly, the more they save, the sooner/faster I get paid). Kinda lame if I have to tell them “oh that great platform I told you to use, yeah sorry it costs you higher costs per impressions for no reason.” :-/

1 Like

You are right. I was having a minor cut webflow some slack moment, but the whole OG & twitter card setup needs an overhaul. Webflow need to fix this. It was half baked years ago.

1 Like

Any update here?

I get the same error in FB debugger — and also having issues on Twitter (see below). Sharing on iMessage is also missing info - guessing this is also related, since my static pages are pulling in fine?

Read only link with OG settings all set…

Here is it on twitter…

iMessage…

1 Like

Not sure if this helps anyone else… but I figured out my issue…

My OG images were SVGs… Facebook didn’t like that. Once I updated to PNGs that were at least 200x200, then it all worked out well!

I also added this code into the head of my CMS page to help Facebook grab the image more quickly and reliably on the first try.
<meta property="og:image:width" content="[your image width]" />
<meta property="og:image:height" content="[your image height]" />

Hope that helps!

3 Likes

This resolved the issue for me! Personally, I’d prefer to paste and delete the url, so that the image/link is generated and the text in the post looks clean, but oh well. Just dropped the link at the bottom of the post and I could run my ad.

1 Like

Thank you! I’ve been trying to figure this out for like 3 hours as to why they wouldn’t show up. Wish Webflow had specified that in Open Graph Settings.