Streaming live at 10am (PST)

Old meta tags showing up


#1

Hi guys,

I finished my design on webflow using a template, and had forgotten to change the name QAPP and the seo for it. I uploaded it to a new server and then changed the page meta tags to the new one but still google is showing the old ones under my site name frowning visusvr.com and whenever I try to post the link, lets say in facebook, it pulls the old tags "QAPP - Webflow template". I know this is not related to webflow anymore but I do not know where else to ask and what to do. I would really appreciate some help please. I also added the whole "og:title" and all required by facebook and google. The regular http is normal but https is still old for the past day. Sorry for long message frowning


#2

Hi @Lizagub, any chance you can provide a link to your site? Don't forget that Webflow has global SEO settings (http://help.webflow.com/seo-basics), but each page also has its settings as well (and these get priority if they are specified). So if you change the global meta tags, but forget to change the page-specific ones, you'll still see old values for those pages.

However, if you did properly set your SEO tags in Webflow, it could be a caching issue. You can use the Facebook Open Graph debugger to force Facebook to refresh the cache for your specific URL: https://developers.facebook.com/tools/debug/


#3

Hi @callmevlad Thank you so much for taking the time to help me.

The site is http://visus.webflow.com/ and it is now hosted on https://www.visusvr.com/

Before exporting the code out of webflow, I did reset the global webflow setting before exporting the code but had forgotten to do so on the page itself, and then like that uploaded to my server on godaddy. THen manually I changed it and added the meta tags for facebook and google and twittet. So now for facebook it works, but whenever I type it into google it is still the old tags frowning

That tool was awesome btw thank you.


#4