Streaming live at 10am (PST)

On mobile the page slides away to left

Hi!
I’m designing a website for a client but I’ve been experience some issues with mobile version. Every time that I scroll down, if I move my finger a little bit to left or right, the page slides away and it does not get back to the centered position. How can I get it fixed and aligned to the center?

PS: The website is in Portuguese.

https://preview.webflow.com/preview/site-institucional-royalglass?utm_medium=preview_link&utm_source=dashboard&utm_content=site-institucional-royalglass&preview=3a9464acb194024994203f89fff36d5c&mode=preview

Up. Anyone can help me?

Hi,

I’m only on here for a few minutes so apologies, but I don’t have time at the moment to dig into it. I would guess that a possible cause is one of your animations starting off screen? It might be worth you taking a quick look at your animations.

Here’s a previous solution that I provided somebody. I hope it helps: Nav bar links only working in desktop layout?

(The solution in that link was in response to an additional question in the thread - NOT the original question asked. Take a look above that post for the additional question that I answer).

1 Like

Hi!
This could possibly be because there is content that is set to be wider than the actual viewport.

I took a screenshot of one example, here the three columns has probably a set width - that is wider than the viewport, which is causing the “sliding to the left”-effect. So you could either make the text or box smaller to fit within the viewport or rearrange it to be in one column and three rows.

Note: It could be more places of the site where the width is wider than the viewport, which is causing the “sliding to the left”-effect. My approach to fix this is to make the viewport the smallest and hover over the white area to locate other parts of the site that is too wide for the viewport.

Hope this helps!

1 Like

Thank you for answering me! I tried to activate the option “Hidden overflow” each and everywhere, but that blank side bar still there. I even tried to delete that section that you screenshotted but it did not work. >>> THIS OPTION 47

Do you have any ideai what can possibly be?

Website Link

I found the problem, it’s this highlighted element:

2019-10-30_18h57_57

If you get rid of this element’s margins, then the horizontal scroll disappears.

If a similar thing happens in the future, just hide each section one at a time until you find the section causing the problem. Then within that section, hide each element one by one and you’ll eventually find what is causing the issue. That’s how I found this :slight_smile:

1 Like

Done! I got it!

Thank you both so much. I’m just getting started on Webflow and I’m learning those basic things. Thanks a lot!

1 Like

Awesome, glad that sorted it for you :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.