Streaming live at 10am (PST)

On Scroll Interactions Stopped Working


#1

Hey guys,

Still new to webflow so I'm hoping there's an easy fix here. My on scroll interactions in the about and support sections were working just fine yesterday. Today I added a new page, used symbols to copy some elements such as the nav bar.. and suddenly my on scroll interactions are no longer working!

The only one that works, thankfully, is the nav bar changing color when you scroll past a certain point.

I've restarted my computer, changed the structure of the sections (they were originally in sections that were 100 vh but I switched it to 100% width auto height... Just hoping that would maybe do something? lol. I've also tried just redoing some of the interactions. No dice. Any insight is appreciated!

https://preview.webflow.com/preview/1pet1vet?preview=2a28381d319e0bf24d397a50656ac537


#2

Can someone please help me? I've spent hours trying to fix this.


#3

Hey @raindrop,

Can you please describe what you expect from this interaction :

On scroll into which view, what do you want to happen ?


#4

@zbrah Hi, thank you.

Originally it had the little div underlines beneath the headers appearing on scroll, as well as having the photo in the support section appear when it scrolls into view.. and all the buttons had a little scale/opacity interaction on scroll as well. I've fiddled with them a lot since then, but if I could just get ANY on scroll interactions to work, then I could easily get those back to doing what I'd like, if they're not currently.


#5

Hi @bart,

Strange things happening here.
Scroll interaction doesn't seems to work / Initial appearance neither.

Am i missing something ?


#6

Not sure if this is relevant or not, but around the time things stopped working I had made a new page, and I copied the navbar over to this page by using symbols. I needed to make changes to it on the about page, so I copy & pasted, then deleted the symbol and added some new classes to edit the one on that page specifically.

Don't know if that has anything to do with the issue or not, just thought I'd share in case.


#7

Hi @raindrop

Thanks for posting this, this definitely sounds like odd behavior.

We are definitely looking into this – hoping to have a resolution as soon as possible.

Thanks in advance for your patience!


#8

Thank you.

Looks like hover interactions aren't working either. Not sure about others as I haven't tried.

Thanks again!


#10

Hi @raindrop thanks for the update. Our team is still looking into the issue.

I will post back here as soon as I have more information! :slight_smile:


#11

Hi @raindrop

Thanks for your patience with this.

We are still working to find a solution to this strange issue.

In the mean time, however, we found a workaround for you.

You can set a scroll out of view interaction that will shrink the line.

GIF: https://cl.ly/2g3v2V2u1D35

Hope this helps for now until we find a fix for this!


#12

Ah, awesome. That is a huge help! Thanks so much!!


#13

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.