Streaming live at 10am (PST)

Open Graph Issues


#1

I recently finalized a clients website and I went to add the Open Graph image. Everything loaded correctly but when I go to share the link on Facebook all I get is this.

Is it because I uploaded it as a Jpeg?

-Sean


Here is my public share link: LINK
(how to access public share link)


#2

Maybe a file is corrupted, maybe... anything :slight_smile: Start by trying again from scratch and follow the good practices, there's no reason for it to bug :slight_smile:

https://www.h3xed.com/web-and-internet/how-to-use-og-image-meta-tag-facebook-reddit


#3

You might also run the link through the Facebook debugger (Google it). Sometimes it just takes time for FB to pickup the correct information.


#4

Thank you guys. I will try these.


#5

Also try without AdBlock


#6

It's so weird. I still can't get this website's Open Graph to work.


#7

Hey @seank it looks like your OG image is being referenced from an external server and is quite large. Make sure your images are around 1200px by 630px and have a 1.91:1 aspect ratio, upload it to your Webflow site and grab the OG image link from your site for that field field instead. ​Please let me know if this solves the problem, if not, I’m happy to help further :slight_smile:


#8

@Waldo ! thank you ... quick question where/how would I grab that link?


#9

@Waldo - I got it to work, but only in the designer per page basis. When I go to my site's settings and place it in the SEO section I receive the following error?


#10

Hey @seank here's a gif above of how to grab that image link for future reference.

This definitely sounds like strange behavior - I'm looking into it right now but haven't been able to reproduce that behavior on my end. Did that happen with just that image? Could you try using a different image link please?

Can you please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode: https://support.google.com/chrome/answer/95464?hl=en
(2) If the problem persists, please take a screenshot of your Console and send it to me: https://developer.chrome.com/devtools/docs/console

Thanks in advance!


#11

@Waldo - Hey when I went into incognito mode it worked - curious why is that?


#12

Hey @seank do you have any browser extensions running by chance?


#13

Yeah I have about 4 running.


#14

@seank I faced the same issue a while back. Try clearing your browser cache and cookies. The reason you are able to view it in incognito is because the browser does not store these elements actively in this mode. Also try sharing from mobile browser to see if the issue persists. I read somewhere that Facebook might require the page URL to be stated explicitly in the meta tag (meta property="og:url").


#15

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.