Streaming live at 10am (PST)

Opening any page opens the same one


#1

Here’s the problem.
I have a CMS Collection with 10 dummies in it.
I put a few Collection Lists on my page, set it up, bind it to different pages.
Let’s say, “A” is a Name of a post, so the link is site.domain/post/A

In my case clicking an item “B”, will trigger the site.domain/post/B page (the link is correct), but contentwise it’s a page A. It was working fine until some point. And it happens with my second project.


https://preview.webflow.com/preview/bk-news?utm_source=bk-news&preview=d87a8cc238949ab0bbbe98544f3e58f6

Here’s a link to another project with the same problem:
https://preview.webflow.com/preview/bknews?utm_source=bknews&preview=01e449136f37ce445fcea6dc0bf645f9


#2

Ok, found it.

You’re clicking the items, Webflow goes to the right post, but the content is always the same…

The reason is:

Inside of the BLOG POST TEMPLATE page, you’ve used a COLLECTION LIST set to blog post. And it’s limited to 1 post starting at 1. That’s why all your blog posts actually show the first post content.

Don’t use collections lists inside of the TEMPLATE pages. (use it only to show content from ANOTHER collection).

So inside of the BLOG POST TEMPLATE, just put elements (title, text, images) and link them directly to the content of the blog posts collection. As it’s a dynamic (CMS) area (the page name is purple), you dont need a collection list element to bing CMS content.

Drag everything from the List to outside the list and everything is going to start working as you expect it to.


#3