Streaming live at 10am (PST)

OTF/TTF Fonts not displaying correctly in Firefox


#1

Hey, new Webflow user here. After watching practically every tutorial I feel confident transitioning my web design work to Webflow. It's amazing that graphic/UI designers with zero experience in coding can create marvelous sites. There's one thing that troubles me, though.
After testing the first section of my site in Firefox, I realized the fonts I've uploaded don't display properly. Both Futura (TTF) and Proxima Nova (OTF) default to Arial. It happens in Firefox only, working great in Safari and Chrome. Any idea what might be causing this?


#2

Hi @deezel , have you also uploaded a WOFF font file to get the Firefox fonts working? Sometimes you need that version of the font file to get it working in Firefox. You can go to www.fontsquirrel.com and generate all different versions of a typeface in the various browser supported formats.

Also, check you are using at least Firefox version 3.5.

I would try that first, then check again, and let us know, and we can look further. Cheers !


#3

Thanks for the lightning fast response, @cyberdave! I have limited experience with typography for the web (worked for print most of my life) and FontSquirrel's tool is extremely helpful. It fixed my compatibility problem instantly, sorry for posting before researching a bit more.

Cheers!


#4

Hi @deezel I am stoked it is working for you now smile No problems at all for asking the question, that is exactly what this community is for smile, to share our workarounds, fixes, custom code or just learn how to use certain functionality in Webflow. Cheers and have a great day!


#5

#6