Streaming live at 10am (PST)

Overflow on Mobile won't go away

Hi all,

I’m having trouble getting overflow on mobile to go away on the Home Page… I’ve made all assets set to overflow hidden, I’ve followed multiple other posts within this forum’s recommendations on placing overflowing images within divs, etc. The overflow doesn’t show up on the designer, and instead only shows up when I actually pull up the read link on my phone.

Any help would be greatly appreciated!


Here is my site Read-Only: Webflow - MapleSmart

And the published preview link: https://maplesmart.webflow.io/

In my opinion because of this circle you have a problem in mobile view.

Thank you for taking a look! I’ve tried removing the circle and it doesn’t make any difference, unfortunately.

.image-4 and .image-9 are the suspect elements because when I remove position absolute on them the scroll disappears.

Hmmm that’s weird, are you sure it’s 9? I’m not seeing a 9 on my composition. In addition, I don’t think those are viewable on mobile?

Hey @abgeter

Easy way to fix this is to set your body overflow setting to hidden.

More difficult way but more proper and better in the long run:

  • Set your “MS_Home_Sec_1” container overflow setting to hidden.
  • Set your “MS_Home_Sec_1” container width to 100%.
  • Set your “Navbar”’ position to Fixed
  • Set your “Navbar” to 100%

Got it, thanks so much Tim!