Streaming live at 10am (PST)

Overflow with custom font


#1

Hey, I uploaded the font: Oswald and overflows the div that it is placed in without automatically skipping to the next row.

http://chief-unicorn.webflow.io/

Any thoughts on this anyone?

Connor


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Hi @finlayconn

Thanks for posting and great question. I did some testing on this end and it looks like the heading is wrapping as expected in the Designer:

On the live site, though, it looks like you have several non-breaking spaces (&nbs;).

If you copy/pasted this text from another application there’s a chance these non-breaking spaces were copied over. Retyping the heading text manually should resolve the issue :slight_smile:

Hope this helps!


#3

Hey,

thanks for your reply, unfortunately that didn’t solve the problem.

I have included the “Share” link for you to check out within the editor.

https://preview.webflow.com/preview/chief-unicorn?preview=833b9263bdc1cf75709775bda7cf1bee

Cheers,
Connor


#4

Some formatting crawled into the text that you have copied from somewhere. Make sure to paste it as non-formatted plain text (one way is to copy your text into the text editor like notepad or the mac alternative and then copy-paste it from there so that all the text formatting is cleared. Another way is to paste the text with ctrl/cmd+shift+v instead of ctrl/cmd+v - this clears the formatting).


#5

Hey,

Thanks for that. I have tried to follow your instructions but am appearing to have the same problems. I set up a style sheet - that’s the only place I have been copying stuff from.

It looks like it is doing it for all my headings - where I set the headings styles as the defaults.

Any other alternative solutions?

Thanks for helping :slight_smile:


#6

Little observation: I don’t have that issue with a text block only with “Headings”.

I have tried the clean copy and pasting. My only guess is that I may have copy & pasted something into an element that I put in my stylesheet.

Anyway I can investigate that?


#7

I dunno mate, clean copy-pasting did it for me on your share link. No idea why wouldn’t it have worked for you


#8

Hi @finlayconn

Sorry to hear you are still having trouble. If I copy paste the text, or re-write it manually on this end the heading text wraps as expected:

If you are seeing other behavior on your end, can you send me a screen recording of what you see (CloudApp or Quicktime work well).