Streaming live at 10am (PST)

Overlay and CMS Items


#1

Hi all, I am fairly new to Webflow and would love to get some help on some issues I’m experiencing with my website. I apologize in advance if these have been addressed elsewhere but I tried googling for solutions but can’t seem to find the answers I’m looking for.

  1. I created a hover overlay on my cms items, but after publishing, it seems the overlay size does not match up with the image size (noticeably much wider). What I noticed was that the images actually became smaller after publishing. How can I get them to match up? I tried a workaround by using flexbox but it was hard to predict since the size shown in designer mode would be drastically different than what is shown when published.

  2. For the nav menu in the mobile versions, how can I have a solid white background upon showing and hiding so that the overflowed text does not sit on top of the remainder of the page. I presume this has something to do with transparencies but I tried changing all the background of the elements to white but nothing changes.

  3. I noticed something odd with the layout of cms items. Instead of sitting neatly one after another, some rows create weird gaps between items. I checked the dimensions of my thumbnails and they all have the same height-to-width ratio so I don’t understand why this is happening.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

I recommend splitting up your questions into separate threads. This makes it easier to reply to.