Streaming live at 10am (PST)

Page folder redirect not working

Hello,

I have a page folder called “old-pages” that I am adding pages to that are not relevant anymore. I have a lot of pages and don’t want to have to deal with redirecting each one.

I believe this is pretty straightforward, but it does not seem to be working.

I have the redirect set up as: “/old-pages/(.*)” going to “https://www.chronicled.com/” (ie my home page)

Here are 2 pages in that folder:


Both pages should redirect to our homepage: https://www.chronicled.com, if I understand it correctly.

Does anyone have any advice?

Mike


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

1 Like

There might be your issue! If you use the wildcard (.*), you should convey the string after the * to the new location too!
Have a look at the guide on the uni:

To redirect an entire folder, add a capture group (.*) in the old URL structure in the “Old Path” Field (eg. /oldfolder/(.)), then add the target path %1 for new URL structure in the “Redirect to Page” field (/entirely/new-url/structure/%1).
You can add multiple capture groups to create more complex redirect rules. For example: **/blogs/(.
)/(.*)** can be redirected to /articles/%1/%2

Ah sorry, have you set your new location via a relative path? You didn’t include the URL schema in it, did you?

Sorry I still don’t understand. I want all pages added to the “old-pages” folder to redirect to my homepage which is www.chronicled.com.

How do I do that? Where do I put the %1?

Mike

That’s not needed in that case. Sorry :slight_smile:
Can you share a screenshot of the exact 301 redirect in the settings?

Screen Shot 2020-07-07 at 1.46.31 PM

Try changing the new path to just / instead of https://www.chronicled.com/

Still not working. Here is a readonly link to my site, if you have a moment to take a look.

https://preview.webflow.com/preview/chronicledstaging?utm_medium=preview_link&utm_source=designer&utm_content=chronicledstaging&preview=fab8d5ba4c4271c20228dad81208785d&pageId=5e387f889619c77a60b2eddb&mode=preview

Maybe my understanding of redirects is off, but based on the fact these 2 pages /protocols and /network are in the old-pages folder, and the rule is set up like this:
Screen Shot 2020-07-07 at 1.52.50 PM

They should both redirect to home page?!?

Have you republished your site? The changes only apply after republish!

Yes I have, multiple times:

This url www.chronicled.com/old-pages/protocols, still doesn’t redirect to homepage?

1 Like

Can you check your existing redirects? It seems you have multiple routes set, if there are any redirects for http://www.chronicled.com/old-pages/protocols specificalle, they will have higher priority.
Make sure there are no conflicting rules!

Nope, no conflicts. Most of the other routes are redirecting to home page as well. Everything that isn’t has nothing to do with this page

You need to add a % before the hyphen. So it would be /old%-pages/(.*)

1 Like

DAMN, completely missed that