Streaming live at 10am (PST)

Page loading wrapper covers only 100VH

Hi!

I have a page loading wrapper - though it is more of a functional workaround to open a specific tab when the button is clicked, rather than a loading wrapper, but I’ll use ‘loader’ for the purpose of this question - then behind the loader is my page, which consists of a tab dashboard.

When creating the page loader, I have set the height to more than 100+vh because my tab content is longer than 100vh, and the bottom of the tab content is otherwise visible when the loader is showing.

This means that the page loader is scrollable when showing, which I don’t want. I would prefer that it was set at 100vh, 100vw.

I don’t have the option to set the tab content to hidden when the loader is showing, because I have a piece of Javascript which only allows the page loader to show once per day. So any views after that single time would result in the tab content not showing.

Is there any way around this? I suspect that it must be quite a simple fix since page content is almost always longer than the page loader… but I just can’t figure it out!

Thanks!! :v:


Here a mockup of the situation: Webflow - Test Triggers

Hey, @ailsargh If the class loading-wrapper is your preloader then make its position: absolute; to position: fixed; full as it will be positioned relative to the viewport, which means it always stays in the same place even if the page is scrolled.

Hope it helps :peace_symbol:

1 Like

Ahh thank you!! It was indeed a simple fix! :grin: