Streaming live at 10am (PST)

Page not found 404

Hi all,

Not sure if this is a bug or it’s me being rubbish.

When you click ‘Ryan French’ top left in nav it results in…

I’ve got it linked to my work page so I assume it should work.

Any tips would be amazing.

Share link - https://preview.webflow.com/preview/designer-ryan?utm_medium=preview_link&utm_source=dashboard&utm_content=designer-ryan&preview=cf36de9db01166856193dbd11a09753a&mode=preview

Hi @ryan585, thanks for your post. I took a quick peek and it seems the link is pointed to the work page at some point, and then the Work page was made the home page in the design.

I would update the link on the Brand Link to point to the Home page or another page other than Work.

Let me know if that does not help.

1 Like

Thanks for the reply.

So that link is pointing towards work, and work is the home page.

I really want that link to point to the work page so is there a fix?

Hi @ryan585,

Do you have a new work page?

if so, you just need to adjust the link.

Its just a matter of reconnecting the link to the page you want. When you initially had it set to the work page it was fine, but as soon at you changed the work page to your default home page the link changed.

Just change it to the page you want to link to.

Actually it is an interesting bug. The link points onto the correct page - homepage (https://designer-ryan.webflow.io/). If you open this link “in new tab” it opens just fine. If you try opening it i the same tab the /null part will be added to the link and the result is 404.

1 Like

Hi @dram, good catch, I think that the expected behavior is for the page to go to 404 when the link target no longer exists.

On the null being added to the link, I am helping to check that further to see what the expected behavior is. I will post back some info as soon as I have an update.

1 Like

Sure, the issue is that target exists! :smiley:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.