Streaming live at 10am (PST)

Page scrolls up after an Element triggers an interaction at the bottom of the page


#1

Hi,

I need help with fixing an inconsistent behaviour on this page.

http://dasubhashitam.webflow.io/workshop/potee

My public share link is below.

Desired Behaviour.

The page has a Registration Form right at the bottom.

It should be hidden after page loads and upon the user clicking the ‘Register Now’ button on the page, it should load and the user should be taken to that section.

What I did.

In interactions, I created Page Trigger to Hide the Registration-Form section ‘When page finishes Loading’.

I created another Element Trigger to ‘Show’ the section on First Mouse click when a user clicks on Register Now button.

Issue.

The Registration-Form section is hidden on Page Load alright. When I click on the Register Now button, the form shows. But the page scrolls all the way to the top instead of putting the Registration Form in focus.

Other quirks.

This doesn’t happen when I render the page on Mobile. It works perfectly.

Works fine too if I apply the interactions on the ‘Container’ inside Registration-form section and not on the section itself.

Appreciate if anyone can unravel the mystery and help fix the problem.

My project share link

Thank you,

Kiran Kumar.


Here is my public share link: LINK
(how to access public share link)


#2

Which page?



#3

When I click register, it sends me to the bottom of the page. Why don’t you consider hiding the form, when the user clicks register it opens like a modal?


#4

http://dasubhashitam.webflow.io/workshop/potee


#5

@Dids, if it sends you to the bottom of the page, then it is working fine. I am seeing inconsistent behaviour. It was sending me to the top of the page. Don’t want to use a modal box because I am unsure how it will render or low end smartphones. Thanks for your response.


#6

I don’t see a bug in the Designer or on the published site. Page scrolls well to the beginning of the form.


#7

@vincent Please see now. I realised I it was set on the Reg-Form-Container show/hide as I mentioned earlier. Now I changed to Section Show/Hide. I can see the page scrolling all the way to the top after I click Register. Curious as to why it happens when the Interaction is set for the Reg-form-section. Thanks for your time.


#8

Bro when it comes to webflow NEVER be afraid - 100vw 100vh keeps things under control #WebflowForLife - just try it and then at least you’ll have an answer


#9

It still behaves as expected.


#10

@vincent Captured the behaviour on camera :slight_smile:

You can see at first when I click on Register, the form opens up (as desired) but scrolls up all the way to the top. Subsequent clicks on the Register Now button give expected results.

CloudApp


#11

Does it happen in n Incognito Window in Chrome? File > New incognito Window.

Maybe your cache, or your extensions are at fault.

I can se 18 visible extension on your Chrome, you shouldn’t use any extension when using Webflow.

An advice: Download Chrome Canary, it’s a development, stable version of Chrome. You can use Webflow with it. https://www.google.com/chrome/canary/

Can you download it and test if the behavior happens there too?


#12

@vincent I see the same behavior on a cache cleared browser, incognito mode, and on Canary.