Streaming live at 10am (PST)

Page Section links not working in rich text blocks


#1

I have a number of rich text blocks on a page. At the top I have a rich text block with links to different sections contained in other rich text blocks. So I create a rich text block and there's a h2 at the top of it that i want to link to. I give the h2 an id. then I go to the top of the page where my page section links are contained in a rich text block. I highlight the work i want to link - the link options appear - i select sections - but the section i've just created (in a rich text block down the page) doesn't show.

I think this only occurs when linking to a page section in a rich text block from a link in a rich text block - if that makes sense.

if you want more info, just ask.


#2

Aren't you giving the ID to the whole RT block rather than only the H2 inside? IDs are per element so I don't think you can ID an H2 inside a RT


#3

Yes, it works when I ID the whole RT block but not when I ID an element in a RT block. I can ID elements in RT blocks and link to them from link blocks of text links so I don't see what it wouldn't work with RT block elements.


#4

Hello @Diarmuid_Sexton

Can you please update your post with some more information so we can help you faster? Things like screenshots and your environment info really speed things up.

Posting guidelines can be found here: http://forum.webflow.com/t/posting-guidelines-for-the-need-help-category/8094

Thanks in advance! :slightly_smiling:


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.