Streaming live at 10am (PST)

Page Transition in published site has delayed loading font or CSS


#1

Hi Webflow community, in the published link the page transitions are delayed, looks like the font or CSS takes a second more to load see the video in this link [https://cl.ly/716f6e1edd7d] I have tested in Chrome and Firefox.

Here is a link to the actual site [http://hermitagehillfarm-wedding-site.webflow.io]
I have tried all within my knowledge and can’t figure it out,
Any help would be greatly appreciated.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

This is normally for custom fonts. For fix it little bug you can do a preloader or fade animation applied to body: https://university.webflow.com/article/preloader


#3

Bro-designs, you a genius! did just that and it looks amazing thanks for the tip.


#4

Hi @earnez

This is a commonly asked question on the forums. In the future, please be sure to search for existing threads before creating a new one. :slight_smile:

This issue is called FOUT (Flash of Unstyled Text) and you can read more on this here: https://webdesign.tutsplus.com/articles/quick-tip-avoid-fout-by-adding-a-web-font-preloader–webdesign-8287

You can fix this by adding a bit of custom code to your site — Dave explains this more here: Flash of unstyled text - fallback fonts loads initially then switches to google font

Alternatively, you can try downloading the Google font, then uploading it to your site as a custom font.

I hope this helps! :slight_smile: