Streaming live at 10am (PST)

Parallax effect not working correctly in Firefox or Internet Explorer


#1

Hi, following the instructions of Nelson, I´m going to post my actual problem with some browsers:

I have done a website with webflow (www.janadasilva.com) and the parallax effect that I did in the home page is no displaying correctly in Firefox and Explorer (it displays correct in Chrome, Safari and Ipad). How can I fix the parallax effect on Firefox and Explorer without to affect the other browsers?

Thanks so much for your help.
Regards,
Jana Da Silva


How can I reduce the height of my body to match the real height
#2

Hi @janads

Can you please update your post with some more information so we can help you faster? Things like screenshots and your environment info really speed things up.

Posting guidelines can be found here: http://forum.webflow.com/t/posting-guidelines-for-the-need-help-category/8094

Thanks in advance! smile


#3

Hi @janads, thanks for the post. I did a quick test on www.janadasilva.com on IE and Firefox for mac, and it is working for me smile are you on mac or pc ? what version of operating system and what version of browser are you using?

I did not see any code errors on the page either in the console. Cheers, Dave smile


#4

Hi! Thanks so much for all replays, so sorry PixelGeek, I didn't see the email that noticed your replay. And thanks so much cyberdave to check my browser issue. I have an OX 10.8 and from this I can see the parallax effect correct at Safari an Chrome, but Firefox display wrong (attached screener). And for Explorer I'm usisng a simulator and this one display the same issue than in Firefox.


#5

I attache as well how it looks in chrome (the correct display of the parallax effect)
Thanks!


#6

Hi @janads, sorry for the long delay in reply, Could you share the site read-only link: http://help.webflow.com/faq/general/how-do-i-share-my-sites-read-only-link, I am happy to take a look and look if I can find out what is happening.

Cheers,
Dave


#7

Thanks so much! this is the link: https://preview.webflow.com/preview/janadasilva?preview=4fc7c53138eb841294b1705ccc7b3f55

Thanks smile


#8

Hi @janads, thanks I am taking a look smile


#9

Hi @cyberdave, any news on this?
Thanks
Jana


#10

Hi @janads, thanks for the followup. I have been looking into this, but I do not have a solution for you yet. It is possible the container that holds the scene might be causing an issue in FF and IE.

Could you try to make a duplicate of the site, and then instead of putting the parallax scene in a container, could you use a div instead and do the following:

a. Set the width to 75%
b. Set the div to left and right margin set to auto

Here is the actual page for this plugin, I think it would be a good idea to post about this trouble there as well, since the plugin is supported from that page:

https://github.com/wagerfield/parallax/issues

This might be a related issue: https://github.com/wagerfield/parallax/issues/84

I am continuing to investigate, but as of right now, I do not have a solution for this.

Cheers,
Dave


#11

Hi @janads, a couple more things for you to try with a duplicate copy of the original site:

  1. Give the section containing the scene, a height of 100%

  1. Give the container a height of 100% and position relative:

  1. Give the Scene class a height and width of 100% and position set to absolute.

I do not know if that will work, as it need to be published....


#12

Thanks so much @cyberdave , I'll follow your instructions and I'll let you know the result.

Thanks and regards,
Jana Da Silva


#13

#14