Streaming live at 10am (PST)

Perplexing behaviors with layout and navigation

I’m experiencing three perplexing behaviors with layout and navigation. Things that at first guess I would say are bugs, but of course, they are probably caused by my lack of sophistication with CSS.

I’ve made a 3-minute video that demonstrates each: http://bit.ly/2R5DyYv

If anyone has any insight as to what is the cause of these behaviors, and how I might be able to fix them, I would really appreciate your advice.


Here is my site Read-Only: http://bit.ly/33DFV7s

No responses to this after 10 days, so just replying myself in order to move it back into visibility in the cue. Still hoping someone may be able to help with this.

@Chuck_Braman Ok for your problem 1. It works fine for me. Show the last row. Expain. Im

@Chuck_Braman Regarding problem 3, same here works fine for me to

@Chuck_Braman the reason the menu option stays blu is because you have used focus. You click the button /focus) the scroll. But the buttin is stikk in focus

Re prob 1, is that just in the editor? Is it there when you publish?

@JanneWassberg, @jhiggins,

Thank you for your help.

Problem #1 seems to have mysteriously disappeared for me too, published and unpublished. I don’t know why it came and went without me changing the code, but in any case, no longer a worry.

Problem #2 still remains. May just be expected behavior that is illogical to me or it may be something that is wrong and that can be fixed, I don’t know.

Problem #3, I suspected it has something to do with focus, but I still have no idea what I can do differently to correct it.

Any further advice/insight regarding #2 or #3 still appreciated, thanks.

@Chuck_Braman Regarding problem #3 it’s easy to fix. Remove the setting om focus to narmal state and it will work as you want

If i wa syou i would remove the visited to. No reason to use it

@JanneWassberg

I know that sounds easy to you, but I’ve spent a very long time and I don’t understand at a all the specifics to do what you’re suggesting. So far as I can tell the settings on all buttons as the same.

If you have an opportunity to demonstrate in a video exactly what I should to, I suspect that that would probably be the only way to convey the information to me in a form I will be able to grasp.

@Chuck_Braman Regarding problem #2 i can’t tell you. But in quite sure it has to do of the size of each div. Some of them are small and they are all on the same page at all the time. They change on top or in the middle depending on how you scroll. My nest guess.

Try adding spave and se what happends

@Chuck_Braman here is a video

@JanneWassberg

Thanks.

I’m either not making the problem clear, or not following your steps correctly, but I think I am.

Here’s a 1-minute video that explains: https://www.loom.com/share/5ee93c37f11b425c9e5d80933299c82e

@Chuck_Braman with this solution the button is high lighted when it’s current Works for scroll and click. If this is not what you want then i can’t help you