Streaming live at 10am (PST)

Phone Nav Menu Won't Appear


#1

When I preview my site on the vertical phone device I'm unable to get the nav menu to appear when I click the hamburger button. It seems as though it is hiding somewhere. I'm able to edit the nav menu but just can't get it to pop up.

Bob M.


Here is my public share link: https://preview.webflow.com/preview/jareds-lawn-care?preview=8329602e90b84c4daad7313f9598ec05

(how to access public share link)


#2

Hey @bobmagstadt

Seems to be working fine for me, did you try it on an actual phone or only in Webflow preview mode? If so, please give the link to the live site.

Thanks!


#3

You got some z-index stuff going on there. Make sure the z-index of your nav button is highest, then the actual div/container that it triggers is just a number below that... Ensuring both are higher than any other custom z-index values you've set for a slider, etc...


#4

I did not actually try it on my phone, but now I have. Your right, it seems to work correctly on my phone. But why doesn't it seem to work correctly in my webflow preview? I'm not sure what you mean by giving the link to the live site.


#5

It didn't work for me initially, then I adjusted with the z-index's of those two things mentioned above and it worked in the preview... Maybe the preview is just acting up a bit...


#6

That's really weird, it worked in preview for me right off the bat .

@bobmagstadt by live site I mean the published site, the link you go to once a site is published.


#7

It's working fine for me... @bobmagstadt and I tested it on my iPhone too.

You can view the live site by what's displayed in the preview link url :wink: @DharmaNode


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.