Streaming live at 10am (PST)

Plain text widget not working from CMS


#1

Something strange has happened as I'm designing my "blog post template" page. As a blogger, I use rewardStyle to get commission on my posts. I made a plain text field in the post template where I can add the widget code into each post. It was actually working in this same manner before today but now the widget isn't loading and its just showing the (broken) plain text code. For the life of me I can't figure out why this is breaking (especially since it was working before). I would be so grateful if someone can point me in the right direction!

Here is the page:
http://www.wethebirdsblog.com/blog/mock-neck-goodness

Under where it says "Get the look" there should be a carousel with shoppable product (the rewardStyle widget). Instead, I'm just getting the plain text.

This is what it looks like when its working:


Here is my public share link: https://preview.webflow.com/preview/wethebirds?preview=24933ee3cec9e2964a2ecaec834b71d4
(how to access public share link)


#2

It's not a but. Code can only go into an HTML widget. Pasted anywhere else, it will only be text, not code. You'd need a custom code CMS element but that doesn't exist yet.


#3

Thanks for the response. I know that custom code isn't actually an option for a CMS element. I was hoping maybe it was something I did since it was working for several weeks while I was building the site and suddenly it just stopped.. sigh


#4

Oh I missed that part... Well that was surely a bug. When you give to a client the possibility to add text, you don't want them to add code, for sure. And for security purposes too.

Now I am sure we will get the code widget in the CMS sooner or later. I'm very sorry for you that you need it now and can't have it or plan to have it.

One of the reasons Webflow works so well is that it ships on a slow pace, one feature after another. I know it's not a big relieve for you actual project issue but it's worth mentionning :smile:


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.