Streaming live at 10am (PST)

Please tell me why my iFrame content is missing

#1

Hello,

The answer to this problem will probably be so simple, I’ll slap myself.

Within Webflow, I want to create this scrolling iFrame, with a calendar inside.
The functioning page is here: http://amrca.com/calendar-2019.html

In the Webflow version, I dragged this embed code into appropriate section:

<iframe title="Calendar 2019 Content" src="http://www.amrca.com/calendar-2019_content.html" width="535" height="600" style="border: 0; center"

It should work in this Webflow page, because the same code works in the live, non-Webflow version. The full src URL is in the code, but why is this area blank?

Here is the Webflow published page, with missing iFrame content:
https://amrca-membership-form.webflow.io/

And here is the read-only page in Webflow. Please look at the index “home” page, named amrca-membership-form:

https://preview.webflow.com/preview/amrca-membership-form?utm_source=amrca-membership-form&preview=762e9800aacc510c5a310652416ba371

Please tell me what I missed. Thank you all so much.

#2

Your webflow site is running on HTTPS and your iframe is trying to load a non SSL resource. That won’t work since the browser won’t load the unsecure framed content. You need to enable SSL on your framed site and then change the protocal to https://.

#3

Thank you. I would have never thought of that!

#4

I would add that the load time on that muse site is very very slow. and the content you are expecting to load is there (when using http://) but you would have to scroll horizontally to see it.
See below,

CloudApp

#6

I cannot see that content in my browser, nor can I scroll horizontally. Is there any way to get this content onto my Webflow page?

#7

Visit your site as standard HTTP http://amrca-membership-form.webflow.io

#8

When I enter http:, it automatically changes to https:.

#9

Right, but you should be able to change it back in your browser then check. Seeing it load won’t solve the problem. The other site will need to be running SSL for it to load, since you have SSL enabled on your project. Then you can tweak code to address the visual issues.

#10

I understand. But how do you visit a site in http: when it is always changing automatically to https:?

#11

I was able to before. Not now. Did you change site settings? Maybe republish?

#12

Not sure - but I haven’t been able to accomplish what you showed on the video. But you are right - it won’t solve the problem anyway. I am in the process of making the original amrca site secure, so then I will tweak the code if necessary. Your suggestions were invaluable - thank you so much.

#13

You might want to just embed this screenshot of the content as an image on the new site while you rebuild the calendar layout in webflow. It will load a lot faster than that other site.

#14

Thank you Jeff, I appreciate that.

#15

@pathfinder - Sure. Glad we could help you move through this issue. - AIRBORNE