Streaming live at 10am (PST)

Pop up modal error

I have an existing site that I am redoing in an effort to streamline and edit. I am working on a new page, currently hidden, called Menus. I have a nav link called Newsletter. When you click it a form window pops up. For some reason when you click it there are 2 issues.

  1. you sometimes have to click it more than once for it to work
  2. it shifts the entire site nav bar included down

the odd thing is that I have it working on another site (not published) and I use the same interaction steps for the pop up modal for reservations and I do not get the error.


https://preview.webflow.com/preview/element-park-city?utm_source=element-park-city&preview=5879d70a6f12d799b5b5355801c9982b(how to access public share link)

Hey Rachel,

  1. You have 2 interactions applied to the newsletter nav link:
    Image%20001
    This means that on 1st click you open the modal, but on every 2nd click your button does the 2nd interaction (Dropdown Hide).

  2. I do not see this behavior on the preview. Is this happens only on the published site?

yes just on published site. I have the same format on the reservations 2 interactions that are essentailly the same and I do not get the issue. I also tried to remove the second interation and I still get the same error

even more odd is that it is working on some pages and not on others

also it’s coming up as a flash on load which is also odd as I do not have a page load trigger @cyberdave can you offer any insight?

I do not know what but I moved the order of the modal under the nav bar in the line up and that seemed to fix the issue. Very odd that it was only affecting the newsletter modal and not reservations but either way its working now