Streaming live at 10am (PST)

Pop-up not working on iOS

Hi guys,

I’ve built a pop-up demo sign up form following this guide (https://webflow.com/blog/how-to-build-a-pop-up-modal-in-webflow). It’s all working perfectly in preview mode, but as soon as I publish the site the button just stops working. (correction: it only doesn’t work on mobile iOS. When I open the page on desktop but force the mobile layout the pop-up also works flawlessly, same for Chrome browser on Android)

I read through some other topics and it mostly seems to be individual bugs causing it, so if someone with more webflow knowledge than me could have a look at it it’d be great.

Note that the “pop up” button only shows up on mobile (landscape & portrait).

Cheers

Here is my site Read-Only: https://preview.webflow.com/preview/umai-homepage?utm_medium=preview_link&utm_source=designer&utm_content=umai-homepage&preview=bf9c484fc45924dbd86774e213ba0c04&mode=preview

Here is my published site: https://umai-homepage.webflow.io/

after some testing: this seems to be an iOS issue. the pop modal is working flawlessly on android/chrome

bumping this as it’s holding me back :face_with_thermometer: really don’t want a redirect on my mobile page

bump. been unable to solve this

Bump… still the same issue. The same is now also occurring to my nav menu button on mobile landscape and portrait, working flawlessly on Android but not doing anything at all on iOS (Chrome as well).

I have no idea what’s causing this and would really appreciate some help here…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.