Streaming live at 10am (PST)

Pop-up window is not working on published site


#1

Hello,

I have a site published built with webflow.

In the event page, there’s a pop-up window for registration that is shown once the user click " get your tickets" button.

It does work on preview mode in the webflow editor.But on the published site nothing happens when I click on the button. I’m not sure why…
It was working a while ago and suddenly stopped working but nothing was changed.

Any help?

Attached is a screenshot from preview mode.

Thanks,
Shachar


Here is my site Read-Only: https://preview.webflow.com/preview/secret-stage?preview=6bb175e0702b1c3c62dbff508f2e5f08

My published site: secretstage.io

(how to share your site Read-Only link)


#2

Hi @Daystar

Are you using some custom code? If so, this update affected some sites recently where something was working but stopped:


#3

Hi @StuM !

No, I’m just using interaction, so when I click on the RSVP button it shows the pop-up window.

It works on preview mode, so I’m not sure what’s the problem :frowning:

Thanks for your help…


#4

There is a HTML embed inside the pop up form. Not sure if that has anything to do with it. Could you remove it and try that?

Might be a start to finding the issue.


#5

I think the HTML is for another pop-up I’m not using. The pop-up I need to be triggered is the RSVP pop-up which is a simple webflow form.


#6

Hi @Daystar, one thing to check first, is that you are trying to load the jqueryui css file over http and it is getting blocked:

Change the http source in the link code that is in the custom code panel of project settings:

Change From:

<link rel="stylesheet" href="http://code.jquery.com/ui/1.11.2/themes/smoothness/jquery-ui.css">

To:

<link rel="stylesheet" href="https://code.jquery.com/ui/1.11.2/themes/smoothness/jquery-ui.css">

After that republish the site.


#7

Hi @Daystar, I was doing some more checking and there is an embed in the pop up payments div on your site, when that is removed, the interaction works ok.

52%20PM

Here is the offending code:

<iframe src="https://ticks.co.il/webWidget.php?i=YZPNS2sANL1" style="border:none; min-width:320px; overflow:hidden; display:block; position: absolute; height:100%; width:100%" allowtransparency="true"></iframe>

Recently we announced some changes regarding custom code, so one thing to check is that custom code tags are closed properly, see more here: We’re going hands-off on custom code

I would update the iframe code to:

<iframe src="https://ticks.co.il/webWidget.php?i=YZPNS2sANL1" style="border:none; min-width:320px; overflow:hidden; display:block; position: absolute; height:100%; width:100%" allowtransparency="true"></iframe>

That should work.

I hope this helps.


#8

Amazing Dave! It works, Thanks so much! @cyberdave