Streaming live at 10am (PST)

Popup modals not working in Safari


#1

Hi guys,
I just made some simple layout changes in my site so it would work on IE, and now it seems like no popup modal will open up in Safari.
The modals work fine in all other browsers and I can't seem to understand the difference when inspecting the elements in Safari.
Can anyone help me figure this out? This is the last thing keeping me from finally finishing the site...

The modals are linked to all the services in the services section, as well as some of the partnerships and bio links.

Thanks in advance! Would really appreciate some insight.


Here is my public share link: LINK
(how to access public share link)


#2

What is the official link of the website?


#3

This is the link to the published website:
http://test-9e8be3.webflow.io/

Is that what you mean?


#4

On Safari for my browser the pop-ups appear but then do not close.

I looked into it in detail and it looks fine to me.

I would recommend to determine how much of the websites traffic that you will have will be using IE and determine if that change was really worth it.

IE is a terrible browser and personally I gave up a long time trying to make it work with IE. I can afford it, my clients typically use macs and don't even know what IE is. You should determine before hand if IE is a major browser for the website's audience and if it is really worth investing resources into making the website IE responsive.

By the way: I saw you used flex box for your interactions. IE does not support flex box. So I would be careful with that.


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.