Streaming live at 10am (PST)

Popup scrolling issues on mobile landscape view

#1

I’ve build a page with a popup overlay containing a multi-step form. As you will see on desktop it opens fine but on the mobile landscape view it is too large to fit in the viewport so I need to allow the user to scroll down when needed. However, it keeps scrolling the background instead.

The page in question is ‘st andrews golf packages’

It obviously looks okay in the webflow designer but if you check it on a live mobile (I used iphone 6) you will see my problem.

Here is my site Read-Only: Link

Here is the live page: Link

Thank you!

1 Like

#2

Hello @kevin.fogarty

What if you set the form wrapper/form backgorund to overflow auto?

You can also disable page scroll when someone clicks the form button.

Piter :webflow_heart:

0 Likes

#3

Hello @PiterDimitrov,

The overflow auto had no effect i’m afraid. How do I disable page scroll when someone clicks the form button?

Thanks

1 Like

#4

Try using the method explained here > https://modal-tutorial.webflow.io/

0 Likes

#5

Those modals are using virtually identical settings to mine, I think what I am trying to do might not be possible. Going to save time and hassle and just have two different forms, one for desktop and tablet which will have the popup modal then another on page for mobile landscape and portrait. Thanks for the suggestions anyway.

0 Likes