Streaming live at 10am (PST)

Pressed state doesn't work on preview or published


#1

Hello Webflowers,

Not sure if this is the right section to post, but here it is...

I have a strange issue with my modal menu button :

On pressed state, the button should scale down a little and it's outer glow disappear.
It works perfectly in the editor, but when switching to preview or published, only the outer glow works, the button doesn't scale down.

Any idea why ?

PS : in preview mode, you have to scroll down to see the icon pop from the top. :eyes:

Any help would be really appreciated, thank you ! :pray:

Here is the read-only


#2

Hi @Laurent_Hayoz

Thank you for the detailed information! I took a look at the site and it looks like the interaction you have on the button is interfering with the transform on the pressed state.

I am looking into this more and hope to have a solution for you soon!


#3

Thank you @Brando for looking into it !


#6

Hi @Laurent_Hayoz

Thanks for your patience while we resolved this for you.

It looks like the issue is stemming from the scroll interaction that brings the Hamburger icon into view. Can you please nest the hamburger icon into a div and place the scroll interaction on that div wrapper instead of the icon?

​Please let me know if this solves the problem! :slight_smile:


#7

Hi @Brando

Thanks a lot for putting effort into that.
I'll give it a try later today and will get back to you !

:+1:


#8

Hi @brando,

My problem is kind of similar but not the same. It works on two other pages but for some reason it doesn't work on the contact us page. I tagged you in the post the other day. I just can't seem to get it working.

Cheers,

Tom.


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.