Streaming live at 10am (PST)

Preview image for facebook and linkedin

Hi,

I was trying to share my website on FB and LinkedIn both didn’t find any images. The preview is empty. What should I do?

You should review and follow the instructions available in the university article.

There is no open graph in my version of webflow. I don’t see it where it supposed to be in the videos.

Tatiana

You can set up the Open Graph settings of any or all of your pages by going to the Page settings of each of your pages.

Pages panel > Page settings > Open Graph Settings

For CMS Pages you do that on the template and add dynamic fields.

It worked for Facebook, but LinkedIn still shows an empty place instead of a picture. What should I do?

First you should understand that services that use Open Graph data, don’t necessarily come back and check each time a share happens. It is better for them to cache the data and reuse it. Each service can decide how long they want to cache data for. You can’t control that. I am not aware of a OG cache clearing function on LI. Suggestion - > Wait 24 hours.

https://www.linkedin.com/help/linkedin/answer/46687/making-your-website-shareable-on-linkedin?lang=en

Hi, I waited more than 24 hours and LinkedIn still didn’t update anything. There no preview picture of my website. Is there anything can be done to fix it?

Well we can’t see your published site since you have not shared it. Normally I inspect issues that way. So give us a hand and share your published site.

this may help :slight_smile:

Let me know if it does.

1 Like

It’s http://stripedtie.xyz/ but I’m not feeling comfortable sharing my LinkedIn profile

There is no open graph data set on your home page or you have not published this site since you made the changes.

I did something in open graph…at least I thought, and Facebook since started to preview my site.
Webflow tutorials don’t match to what I see in my settings. It’s extremely confusing. I really don’t know what to do. The videos are not helping.

Your Open graph settings are not set:

CloudApp

Follow this article to fix this:

Hope this helps :slight_smile:

Thank you for the reply. Looks like I figured it out now.

I just don’t understand why other websites like Facebook and LinkedIn can’t generate a preview from Webflow automatically.

Because they standardized on Open Graph. Glad your issue is resolved.

I don’t know what I’m doing wrong, but I still can’t get the preview on LinkedIn even after I added an image in Open Graph settings.

I updated the link with my portfolio and waited a few days, but no change.

You should set your site up correctly for SSL. If linked in is checking via SSL, it would be blocked as there is a certificate error.

I see now. Thanks!

Tatiana

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.