Streaming live at 10am (PST)

Preview looks good. Published site not so much


#1

Hi guys,

I have a website that has been giving me some headaches of late and was hoping someone could steer me in the right direction.

In the designer, as well as the preview, the site looks good. Where I’m stuck is, after publishing the site, on the homepage, the ‘our recent works’ section breaks. Here is a link to the published site: http://multi-pro-roof-solutions-1562529f749162.webflow.io/

If someone can save me a couple hours of headaches/ guess-and-check work, I would be extremely grateful.

Thanks in advance,


Here is my site Read-Only: https://preview.webflow.com/preview/multi-pro-roof-solutions-1562529f749162?preview=af628f0b6e5572254d78ca90855e0a93


#2

Hi @matthews

Can you detail how it’s breaking - maybe a screenshot comparison of what you are seeing?

I’m not seeing anything broken as such… :slightly_smiling_face:


#3

Of course! Thanks for reaching out!

Here is what I see after publishing.


#4

Hmm that’s strange - any custom code used anywhere?


#5

Nowhere.

To add to my confusion, I opened the published page on Internet Explorer and it looks fine.


#6

Can you remove float and clear settings, then set the width to 33.3%? Curious if it still occurs. :sunglasses:


Click to expand the whole image.


#7

Appreciate the suggestion.

Gave it a shot and republished. Unfortunately, got the same result (screenshot below)


#8

Can you try to make the Div block 8 position relative and then remove the margin bottom of the project overlay?


#9

Here’s is my other suggestion and it’ll work for sure!

Make the collection list display flex with the following settings:

And then change the collection item width to 33.30% (33.33% doesn’t work for some reasons)


#10

YES!!! THANK YOU DONALD!!!

That worked. Everything is lined up correctly. I can’t tell you how big of a weight you just took off my shoulders.

Also, thank you everyone for your suggestions. I love this community.