Streaming live at 10am (PST)

Probelm running the website on Internet Explorer


#1

Hello, my website runs great on Chrome, Firefox and Safari, but has some serious issues when running on Internet Explorer.
Can someone help me?

This is my preview link: https://preview.webflow.com/preview/lilach-shapira?preview=ea9e89d657b2432bc5e0112d148effa9

Thank you,
Naama.


#2

Hello Naama!

Internet Explorer has stopped being supported and updated by Microsoft as of January 12, 2016. No matter what software you use or if you hand write websites internet explorer will not accurately depict what you have created.

https://www.microsoft.com/en-us/windowsforbusiness/end-of-ie-support


#3

Hi @DasSean, thank you for your response.
Unfortunately, people are still using IE, so what do you think would be the right answer to my customer?


#4

I run a website that has had about 13,500 visitors over the past 30 days, and fewer than 150 of those people were using Internet Explorer. That’s less than 1%.

Deprecate it. Don’t cripple your site for +99% of your visitors because of the people who are using 10 year old PCs. Which group is going to spend more money?


#5

Thank you @Cricitem, you’ve definitely convinced me!


#6

Hi Naama

IE11 support does not end until 14/11/2025, though older versions are now unsupported. I had a similar and just added the following line (which you want just after the <head> statement):

<meta content="IE=EmulateIE10" http-equiv="X-UA-Compatible">

This might do it if you add right at the top of your Head Code custom code. If it doesn’t work try right clicking outside the site page in your browser and select View page source. The line really needs to be under:

<head>
<meta charset="utf-8">

— so here —

Might be worth a try, and you can always remove it. There’s also equivalent code you can add to your .htaccess file if better for you. Just let me know.

Mike


#7

Hi @pnewest, thank you for your help. Unfortunattly it doesn’t work… I think I’ll add a text line only for IE users, recommending them to use other browsers.


#8

How about trying the following in your .htaccess file:

<FilesMatch "\.(htm|html|php)$">
    <IfModule mod_headers.c>
        BrowserMatch MSIE ie
        Header set X-UA-Compatible "IE=Edge,chrome=1" env=ie
    </IfModule>
</FilesMatch>

Here’s some details on the above: http://www.validatethis.co.uk/news/fix-bad-value-x-ua-compatible-once-and-for-all/

Mike


#9

But how do I reach the .htaccess in Webflow?


#10

Ah, are you hosting with Webflow? Then might not be possible yet - see - Add code in htaccess

If you have access to a host you could try exporting your code and copy it over. Then add the IE code above to a .htaccess file and test. At least you would know if it works for your site. There are variations on the problem, i.e., <IE11 browser, those using/not using compatibility mode etc. So might take a little trial and error and some Google research.

Good luck!


#11

Hi Naama,

I’m not sure on the .htaccess side of things, but I would highly recommend you use a browser update prompt for this issue.

See the sites below, they’re dedicated to helping you resolve the exact issue you’re facing with IE.

https://browser-update.org/


#12

Love it, thanks.

As far as I understand, and I’m no expert, you use .htaccess for 301 diverts if you are not hosting with Webflow. (I use an Excel spreadhseet with formulas to create mine) If you are, use the 301 diverts in the project settings.


#13

This topic was automatically closed after 60 days. New replies are no longer allowed.