Streaming live at 10am (PST)

Problem adding slides to slider


#1

Simple problem here but I’m stuck…

I’ve followed the tutorial for creating a slider, and it worked fine for the first slide. The second slide, however, doesn’t work for me. I’ve created a class called Slide 2, set a background image, added title, subtitle, button etc. elements in a container and set in flexbox as I did in the first slide. Now it seems like all the elements in this slide are placed outside the mask for some reason and I can’t figure how to fix it. Any ideas?

Share link: https://preview.webflow.com/preview/docushuk?preview=edc8d2b51e10ee18760d853be07d90d2


#2

Hiya @yeshai - The issue is adding flex box to the slide panes. Slider don’t like this. Remove the flex box settings from the slide panes, add a div block inside each slide container and add the flex box settings to those (and move your content inside the div blocks). Actually, you don’t need to use flex box for the content you have… Just remove the flex box settings on both slides and add top padding to your containers! Hope this helps! Regards Kai


#3

Thanks @Keejo for your reply. I tried this, but it didn’t work. The container on the second slide still seems to be outside the mask, as is the background image.

BTW - I used flexbox as it was suggested in the Webflow tutorial.


#4

Hi @yeshai - give your Slide Nav a z index of 1… try that! :slight_smile:


#5

Thanks again @Keejo, but no cigar. This is really odd and frustrating :confused:


#6

SORRY @yeshai ! Maybe start again with a new slider? …this can fix issues sometimes! Good luck! :slight_smile:


#7

You can use flex box in sliders but not on the slide panes themselves… this messes things up… :slight_smile:


#8

OK I’ll give it another go - this time no flexbox… Appreciate your effort @Keejo :cowboy_hat_face:


#9

its my pleasure… hope you get it sorted… :smile:


#10

Yeah looks like it works now. Guess I’ll avoid flexbox on sliders in the future.


#11

Great! :slight_smile: yes, but only on the panes… you can add div blocks to slide panes and use flex box on those… All the best! Kai


#12

This is correct. Do not modify the display or responsive visibility settings of Webflow components. Put divs/containers around/inside them and style those instead.


#13

Hey there! Sometimes you can’t find the reason for the error. keejo was right. You should start with new slider. And follow his instruction. Maybe it can help you this time.


#14

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.