Streaming live at 10am (PST)

Problem with 301 redirects


#1

Hi all,

Just managed to get our company's webflow site up and running! Really happy with it, just having a problem with the 301 redirects. On google search when you type in the company name (eSight) the site structure comes up as per the old website. but certain pages when clicked just come straight to the new webflow site's 404 error page even though we've changed the 301 redirects to go to the corresponding new pages!

For example one of the pages that comes up when you google search eSight is the eSight "FAQ" page. when you click on that page it should send you to : "www.esighteyewear.com/faq" but instead clicking on the FAQ button goes straight to "www.esighteyewear.com/faq/" notice the extra "/" and this in turn gives the 404 error page... I've even added this extra dash as a redirect entry but to no avail. any tips? is this making any sense?


#2

Looks like it's not letting you add /faq/ as a redirect because there is already a page in your site called '/faq' (without slashes). Two options that I can think of to resolve this...

a) rename /faq in your Webflow page to something else... (like '/frequently-asked-questions')
b) Use the google webmaster tools and ask them to recrawl your website

Not sure if option B would fix it right away but the minimum you'll tell Google that you have a new site structure and they can update their search results to reflect that.


#3

The thing is, its happening even for pages that are not identically named. I tried redirecting an old page: "www.esighteyewear.com/esight-eyewear/" to the newer version of that page: "www.esighteyewear.com/what-is-esight" but when I click on the google link it still takes me to "www.esighteyewear.com/esight-eyewear/" in the address bar and the 404 error page for the web page...

In the meantime I'll try letting google know through the webmaster tools. Any more insight would be appreciated.


#4

Hi it does seem like redirect target paths that end in / are not being redirected properly - will look into this and provide an update soon.


#5

Hi @brryant. I'm encountering this same issue and none of my redirect pages have identical matches on the new site. Most have a trailing / though. We need this working ASAP otherwise people will be getting 404 errors and we will drop in search rankings.


#6

Oh, it looks like if you omit the / it works fine!


#7

Hi there, none of our 301 redirects seem to be working. Some have trailing / some dont. None of them share the same name. www.eshots.com is our domain and as an example http://www.eshots.com/experiential-marketing-platform-technology should redirect to http://www.eshots.com/solutions-technology but it doesn't.

Please see the attached image...


#8

Hi @eshotsinc - seems to be working for me:
~ ᐅ curl -I http://www.eshots.com/experiential-marketing-platform-technology
HTTP/1.1 301 Moved Permanently
Content-Type: text/html
Location: http://www.eshots.com/solutions-technology
Server: openresty
Content-Length: 178
Accept-Ranges: bytes
Date: Tue, 11 Aug 2015 22:02:14 GMT
Via: 1.1 varnish

Have you published your site? You will need to in order for changes to take effect.


#9

It seems the 301 Redirect feature has changed. The Redirect TO Page is now a open field, instead of a dropbox. How can I redirect pages to my Home Page now if I can't leave the Redirect to Page as "/"?


#10

I still have this question. Anybody?

:smile:


#11