Streaming live at 10am (PST)

Problem with creating a bunch of buttons each with an image, text and a link


#1

I am having difficulty trying to create a button with an image, text and a link.
tried many different approaches but none has worked.
I know you cannot have a link within a link.
1. Since an image doesn't have a link I tried putting an image to a button but the image looked lousy.
2. I then created a link block and added an image. the image looked great but no text is available. I had to create a separate text block. I then realized that since I needed to put multiple images in a line block I would have a problem because each image needs a link.
3. When I put a text block inside a line block there is a line under the text and both are in blue color. Why is that?
4. So should I create a line block for each image, then add a text block for each line block?
5. Also I would like to put a background image behind all these images but since I am in a container the bckground image goes well beyond the buttons.
6. Please see my public link:
http://ci-assistant.webflow.com/

thanks.


#2

Click on Try it and you will see the screen I am having problems with.


#3

I'm not sure I get your issue.

By the way check the 1st post of the forum to know how to make a real public link.

Here's a public link to a page I've done a button with text and image background, using the Button element. Check how it's made. https://webflow.com/design/sab?preview=c8e9203ce4585987e1e74923be4eda13


#4

Thanks.
I just would like to know how to create the 9 buttons with text, image, link and background, that is displayed in my published site ( sorry not public link). I am unable to do it without having a line block with an image in it.
I have tried what you have done and the image does not display as nice as a line block with a button.


#5

Watch my example, make it an inline element and multiply it 8 times...


#6