Streaming live at 10am (PST)

Problem with Firefox and Flexbox


#1

hey guys.
one thing.

i am experiencing a very strange bug on firefox 43.0.3 running on el capitan 10.11.5. please have a look at the screenshots. the first one is how it should look like (and looks in chrome, safari, …) and the second one is how it looks like in firefox. it seems like a problem with the new flexbox feature. but i cant figure out whats happening here. please help.


thank you!
jaro.


Here is my public share link: LINK


#2

Hi @buntestrahlen, could you help to share the exact url of the published site, having the issue?

Thanks in advance!


#3

of course. sorry. here you go. :slight_smile:


#4

Hi @buntestrahlen, here is how it looks to me, with the latest version of firefox (version 47):

Does this look correct? I noticed you were using Firefox version 43, also using El Capitan 10.11.5, could you upgrade to the latest version of Firefox and see if the issue is still present?

Nice site by the way, the 3d transforms are working fine for me in Firefox.

Thanks in advance!


#5

hey dave.
thanks for your compliment. i really appreciate that! :slight_smile:

your screenshot looks good. after updating to v47 it looks good for me too. but dont you guys want to give overall support for every major browser plus a few older versions? i think of all the people visiting my website using an older firefox version.


#6

Hi @buntestrahlen, thanks for getting back to me. It is very difficult to keep support for browsers that have been outdated.

Generally we provide support for the latest browsers as people should update there systems anyway due to security and compatibility issues in the browser.

Older browsers may work, but we only support the latest browser versions.

In this case, the components used on the site are something that the earlier versions of firefox just don't support, so to keep compatibility with as many browsers as possible, create the design using features that are supported.

In this case, Flexbox is not supported in Firefox earlier than version 45: http://caniuse.com/#feat=flexbox

I would use that caniuse site as a guide to know what kinds of css/javascript/other features will be compatible: http://caniuse.com/#index

I hope this helps!


#7

hey man!
thank you so much for your detailed response. i fully understand.

:sunny:


#8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.